Error with Windows 10 Enterprise....

Comments, questions, bug reports, etc.
cacheman
Posts: 5
Joined: Thu Aug 06, 2015 1:56 pm

Error with Windows 10 Enterprise....

Post by cacheman »

Hi....

Like the new website ;) .

I have been trying out wimlib-imagex apply on vanilla Windows 10 Enterprise install.wim (x64 and x86), but I keep getting the error below.

I have tried this with wimlib-1.8.1 and wimlib-1.7.1 on partitions created using mkntfs from ntfs-3g 2015.3.14.

Is it too soon to use wimlib on Windows 10?

TIA

Chris.



wimlib-imagex apply ./install.wim 1 /dev/sdb1
Applying image 1 ("Windows 10 Enterprise") from "/tmp/nfs/unattended-windows/install/os/test/i386/windows10-sp0/sources/install.wim" to NTFS volume "/dev/sdb1"
[ERROR] Failed to set security descriptor on "/Program Files/WindowsApps" in NTFS volume: Invalid argument
The security descriptor is: 010014941400000034000000c401000054000000010600000000000550000000b589fb381984c2cb5c6c236d5700776ec0026487010600000000000550000000b589fb381984c2cb5c6c236d5700776ec0026487020070010c00000000002800ff011f00010600000000000550000000b589fb381984c2cb5c6c236d5700776ec0026487000a280000000010010600000000000550000000b589fb381984c2cb5c6c236d5700776ec002648700003800a9001200010a00000000000f03000000000400008107aed8d185cf96c0176a3b1aee8470db005fe5e3c781c533949d3afc431f95000b3800000000a0010a00000000000f03000000000400008107aed8d185cf96c0176a3b1aee8470db005fe5e3c781c533949d3afc431f9500001400bf011200010100000000000512000000000b14000000001001010000000000051200000000001800a900120001020000000000052000000020020000000b1800a90012000102000000000005200000002002000000001400a0001200010100000000000513000000000b1400a900120001010000000000051300000000001400a0001200010100000000000514000000000b1400a900120001010000000000051400000002001c00010000001103140001000000010100000000001000100000
ERROR: Exiting with error code 59:
Failed to set file owner, group, or other permissions on extracted file.
synchronicity
Site Admin
Posts: 355
Joined: Sun Aug 02, 2015 10:31 pm

Re: Error with Windows 10 Enterprise....

Post by synchronicity »

Hi,

Thanks for the problem report. I actually observed this same problem recently and am worried a lot of people will start running into it. This is caused by a bug in libntfs-3g (not in wimlib). Some security descriptors in Windows 10 installation images contain more "subauthorities" than libntfs-3g expects, which causes libntfs-3g to reject the security descriptor. This was fixed in the development version of NTFS-3g (git://git.code.sf.net/p/ntfs-3g/ntfs-3g, branch "edge"). But based on their release schedule the fix won't be in an actual NTFS-3g release until 2016.

On wimlib's side it is difficult to work around this because in the presence of this bug it simply isn't possible to set the correct security descriptor. The obvious workaround is to have wimlib just skip the security descriptor on affected files, but that isn't a good idea in general because it can introduce security vulnerabilities into the installed Windows system. I'll have to think about whether there are any other possibilities.
cacheman
Posts: 5
Joined: Thu Aug 06, 2015 1:56 pm

Re: Error with Windows 10 Enterprise....

Post by cacheman »

Hi....

Thanx for the swift reply. I could try the dev version of ntfs-3g....I don't really use it for much beyond PC imaging.

If I update my ntfs-3g to the git edge branch, do I need to rebuild wimlib?

TIA

Chris.
synchronicity
Site Admin
Posts: 355
Joined: Sun Aug 02, 2015 10:31 pm

Re: Error with Windows 10 Enterprise....

Post by synchronicity »

It looks like it would be safe to just install the updated libntfs-3g.so, but to be safe I suggest rebuilding wimlib against the updated libntfs-3g since libntfs-3g is not guaranteed to be binary compatible between releases.
LaserOfFury
Posts: 1
Joined: Thu Jan 07, 2016 3:30 pm

Re: Error with Windows 10 Enterprise....

Post by LaserOfFury »

I have also gotten this issue when trying to apply a Windows 10 Pro image.

I swear I've gotten it to work once using the edge branch of ntfs-3g however I currently can not get it to work.

I'm using the latest download from the ntfs-3g edge branch 'make install'
and I'm using the latest beta of Wimlib (1.9.0 BETA5). Ive tried building wimlib after the ntfs-3g build but no luck.

I still get the security descriptor issue.

*FIXED: My solution was:

apt-get purge ntfs-3g
inside the ntfs-3g folder after ./autogen.sh and ./configure. run 'make install'
inside the wimlib folder after ./configure run 'make install'

The key is to run 'purge' on apt-get. This may be a noob mistake I made but just for anyone wondering, this is what i did.
synchronicity
Site Admin
Posts: 355
Joined: Sun Aug 02, 2015 10:31 pm

Re: Error with Windows 10 Enterprise....

Post by synchronicity »

For future reference:

This bug has been fixed in the latest stable release of NTFS-3G, version 2016.2.22.

To solve the problem, upgrade to NTFS-3G version 2016.2.22. It is also necessary to rebuild wimlib afterwards, since libntfs-3g.so uses a new library version number.
rsh
Posts: 2
Joined: Thu Sep 01, 2016 2:19 pm

Re: Error with Windows 10 Enterprise....

Post by rsh »

i got the exact same error with this win10 Image:
en_windows_10_enterprise_2016_ltsb_n_x86_dvd_9058202

But im already using the NTFS-3G version 2016.2.22.
synchronicity
Site Admin
Posts: 355
Joined: Sun Aug 02, 2015 10:31 pm

Re: Error with Windows 10 Enterprise....

Post by synchronicity »

rsh wrote:i got the exact same error with this win10 Image:
en_windows_10_enterprise_2016_ltsb_n_x86_dvd_9058202

But im already using the NTFS-3G version 2016.2.22.
Then you must have run into a different bug, such as the one described here which was fixed more recently: http://tuxera.com/forum/viewtopic.php?f=2&t=31167

I can confirm this if you post the exact error message you received, including the security descriptor hex.
rsh
Posts: 2
Joined: Thu Sep 01, 2016 2:19 pm

Re: Error with Windows 10 Enterprise....

Post by rsh »

is this enough for you to help me?

Code: Select all


Executing the command: wimlib-imagex apply /mnt/depot/temp/OS-windows10.enterprise.ltsb.n.x86-9058202.zip/install.wim 1 /dev/sda2
Applying image 1 ("Windows 10 Enterprise N 2016 LTSB") from "/mnt/depot/temp/OS-windows10.enterprise.ltsb.n.x86-9058202.zip/install.wim" to NTFS volume "/dev/sda2"


[ERROR] Failed to set security descriptor on "/Program Files/WindowsApps" in NTFS volume: Invalid argument
The security descriptor is: 010014941400000034000000c401000054000000010600000000000550000000b589fb381984c2cb5c6c236d5700776ec0026487010600000000000550000000b589fb381984c2cb5c6c236d5700776ec0026487020070010a00000000002800ff011f00010600000000000550000000b589fb381984c2cb5c6c236d5700776ec0026487000b280000000010010600000000000550000000b589fb381984c2cb5c6c236d5700776ec002648700003800a9001200010a00000000000f03000000000400008107aed8d185cf96c0176a3b1ae...
...e8470db005fe5e3c781c533949d3afc431f95000b3800000000a0010a00000000000f03000000000400008107aed8d185cf96c0176a3b1aee8470db005fe5e3c781c533949d3afc431f9500001400ff011f00010100000000000512000000000b14000000001001010000000000051200000000021800a90012000102000000000005200000002002000000031400a900120001010000000000051300000000031400a900120001010000000000051400000009004000a90012000102000000000005200000002102000061727478f81c000000570049004e003a002f002f005300590053004100500050004900440087000002001c0001000000110314 0001000000010100000000001000100000

This error occurred because libntfs-3g thinks the security descriptor is invalid.  If you are extracting a Windows 10 image, this may be caused by a known bug in libntfs-3g.  This bug was fixed in NTFS-3G version 2016.2.22.  See: https://wimlib.net/forums/viewtopic.php?f=1&t=4 for more information.



synchronicity
Site Admin
Posts: 355
Joined: Sun Aug 02, 2015 10:31 pm

Re: Error with Windows 10 Enterprise....

Post by synchronicity »

Yes, it is indeed the bug which was discussed on the NTFS-3G forum thread I referenced above. It was fixed by an NTFS-3G patch only six weeks ago, so the fix is not yet present in a stable NTFS-3G release. If you are interested, you can find the latest NTFS-3G code at repository git://git.code.sf.net/p/ntfs-3g/ntfs-3g, branch "edge".
Post Reply