Remove support for --enable-more-assertions configure option