]> wimlib.net Git - wimlib/blobdiff - rpm/wimtools.spec
win32_apply.c: fix extraction of empty reparse points
[wimlib] / rpm / wimtools.spec
index d457f9a5071644760af0903080d7aff517d73007..1d39f46d518f19be09b7f28f1061c1d6c754d81e 100644 (file)
@@ -1,6 +1,6 @@
-Summary:   Library to extract, create, modify, and mount WIM files
 Name:      wimtools
-Version:   1.5.0
+Summary:   Tools to create, extract, modify, and mount WIM files
+Version:   1.8.1
 Release:   1
 License:   GPLv3+
 URL:       http://sourceforge.net/projects/wimlib
@@ -8,14 +8,9 @@ Packager:  Eric Biggers <ebiggers3@gmail.com>
 Source:    http://downloads.sourceforge.net/wimlib/wimlib-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
-Requires: libxml2, libfuse2, fuse, openssl
-Requires: ntfs-3g
-BuildRequires: libxml2-devel, fuse, fuse-devel, openssl-devel, libattr-devel
-BuildRequires: ntfs-3g-devel, ntfsprogs, libtool, pkg-config
 
-Summary: Tools to create, extract, modify, and mount WIM files
-Group:    Applications/System
-Requires: libwim9
+Group:  Applications/System
+Requires: libwim15
 %description
 Tools to extract, create, modify, and mount WIM (Windows Imaging) files.  WIM is
 an archive format designed primarily for archiving Windows filesystems.  It
@@ -23,7 +18,7 @@ features single-instancing and LZ77-based compression and is used by Microsoft
 to distribute and deploy Windows Vista and later.  WIM files are normally
 created by using the `imagex.exe' utility on Windows, but this package contains
 a free implementation of ImageX called "wimlib-imagex" that is designed to work
-on both UNIX and Windows.
+on both UNIX-like systems and Windows.
 
 In addition to the usual extract/create/update support, wimlib-imagex allows you
 to mount WIM images readonly or read-write, and it even allows you to extract or
@@ -34,39 +29,40 @@ WIM file, such as the install.wim distributed on the Windows installation media.
 This package also contains a script to make a customized Windows PE image based
 on the capabilities provided by wimlib-imagex.
 
-%package devel
+%package -n libwim15-devel
 Summary:  Development files for wimlib
-Group:     System/Libraries
-%description devel
+Group:  Development/Libraries
+%description -n libwim15-devel
 Development files for wimlib
 
-%package -n libwim9
-Summary:   Library to extract, create, modify, and mount WIM files
-Group:    Development/Libraries
-%description -n libwim9
+%package -n libwim15
+Summary:  Library to extract, create, modify, and mount WIM files
+Group:  System Environment/Libraries
+Requires:  fuse
+BuildRequires: libxml2-devel, fuse, fuse-devel, openssl-devel, libattr-devel
+BuildRequires: ntfs-3g-devel, ntfsprogs, libtool, pkgconfig
+%description -n libwim15
 wimlib is a C library for extracting, creating, modifying, and mounting WIM
 (Windows Imaging) files.  WIM is an archive format designed primarily for
 archiving Windows filesystems.  It features single-instancing and LZ77-based
 compression, and is used by Microsoft to distribute and deploy Windows Vista and
 later.  wimlib is an independent implementation of an API for handling WIM
-files, available on both UNIX and Windows, that provides features similar to
-Microsoft's WIMGAPI, as well as additional features such as support for pipable
-WIM files and programatically making changes to WIM images without mounting
-them.
-%post -n libwim9 -p /sbin/ldconfig
-%postun -n libwim9 -p /sbin/ldconfig
+files, available on both UNIX-like systems and Windows, that provides features
+similar to Microsoft's WIMGAPI, as well as additional features such as support
+for pipable WIM files and programatically making changes to WIM images without
+mounting them.
+%post -n libwim15 -p /sbin/ldconfig
+%postun -n libwim15 -p /sbin/ldconfig
 
 %prep
 %setup -q -n wimlib-%{version}
 
 %build
-autoreconf -i -f
 %configure --prefix=/usr               \
            --disable-rpath             \
           --with-libcrypto             \
           --with-ntfs-3g               \
-          --with-fuse                  \
-          --enable-xattr
+          --with-fuse
 make %{?_smp_mflags}
 
 %install
@@ -76,23 +72,21 @@ make DESTDIR=%{buildroot} install
 %clean
 rm -rf %{buildroot}
 
-
 %files
 %defattr(-, root, root)
 %{_bindir}/*
 %doc %{_mandir}/man1/*.1.gz
-%doc %{_mandir}/man1/*.1
+%doc README COPYING COPYING.GPLv3
 
-%files devel
+%files -n libwim15-devel
 %defattr(-, root, root)
 %{_libdir}/libwim.a
 %{_libdir}/libwim.so
 %exclude %{_libdir}/libwim.la
 %{_includedir}/wimlib.h
 %{_libdir}/pkgconfig/wimlib.pc
-%doc AUTHORS COPYING README
 
-%files -n libwim9
+%files -n libwim15
 %defattr(-, root, root)
 %{_libdir}/libwim.so.*
-
+%doc COPYING COPYING.GPLv3 COPYING.LGPLv3