]> wimlib.net Git - wimlib/blobdiff - rpm/wimlib.spec
Improve handling of invalid filenames
[wimlib] / rpm / wimlib.spec
index 4ab654dc0c815276268aa6e0d6f2d53e256e46f9..eb67a48f840884eacc42f490e168b14032f13d31 100644 (file)
@@ -1,10 +1,10 @@
-Summary:   Library to extract, create, and modify WIM files
+Summary:   Library to extract, create, modify, and mount WIM files
 Name:      wimlib
-Version:   1.1.0
+Version:   1.4.0
 Release:   1
 License:   GPLv3+
 Group:     System/Libraries
-URL:       http://wimlib.sourceforge.net
+URL:       http://sourceforge.net/projects/wimlib
 Packager:  Eric Biggers <ebiggers3@gmail.com>
 Source:    http://downloads.sourceforge.net/wimlib/wimlib-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
@@ -14,11 +14,9 @@ Requires: ntfs-3g >= 2:2011.4.12
 BuildRequires: libxml2-devel, fuse, fuse-devel, openssl-devel, libattr-devel
 BuildRequires: ntfs-3g-devel >= 2:2011.4.12, ntfsprogs
 %description
-wimlib is a library that can be used to create, extract, and modify files in the
-Windows Imaging Format. These files are normally created by the 'imagex.exe'
-program on Windows, but this library provides a free implementation of 'imagex'
-for UNIX-based systems. wimlib supports mounting WIM files, just like
-imagex.exe.
+wimlib is a C library for creating, extracting, modifying, and mounting files in
+the Windows Imaging Format (WIM files).  It is similar to Microsoft's WIMGAPI
+but is designed for both UNIX and Windows.
 
 %package devel
 Summary:  Development files for wimlib
@@ -27,44 +25,56 @@ Requires: %{name} = %{version}-%{release}
 %description devel
 Development files for wimlib
 
+%package -n wimtools
+Summary: Tools to create, extract, modify, and mount WIM files
+Group:    Applications/System
+Requires: %{name} = %{version}-%{release}
+%description -n wimtools
+Tools to create, extract, modify, and mount files in the Windows Imaging Format
+(WIM files).  These files are normally created by using the `imagex.exe' utility
+on Windows, but this package contains a free implementation of ImageX called
+"wimlib-imagex" that is designed to work on both UNIX and Windows.
+
 %prep
 %setup -q -n %{name}-%{version}
 
 %build
-%configure --prefix=/usr                 \
-           --disable-rpath               \
-          --with-libcrypto              \
-          --with-ntfs-3g                \
-          --enable-xattr                \
-           --disable-verify-compression
-%__make %{?_smp_mflags}
+%configure --prefix=/usr               \
+           --disable-rpath             \
+          --with-libcrypto             \
+          --with-ntfs-3g               \
+          --with-fuse                  \
+          --enable-xattr
+make %{?_smp_mflags}
 
 %check
 make check
 
 %install
-%__rm -rf %{buildroot}
-%__make DESTDIR=%{buildroot} install
+rm -rf %{buildroot}
+make DESTDIR=%{buildroot} install
 
 %clean
-%__rm -rf %{buildroot}
+rm -rf %{buildroot}
 
 %post -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
 %files
 %defattr(-, root, root)
-%doc AUTHORS COPYING README TODO
-%{_bindir}/imagex
+%doc AUTHORS COPYING README
+%{_libdir}/libwim.so.*
+
+%files -n wimtools
+%defattr(-, root, root)
+%{_bindir}/wimlib-imagex
 %{_bindir}/mkwinpeimg
-%{_libdir}/libwim.so
-%{_libdir}/libwim.so.0
-%{_libdir}/libwim.so.0.0.0
 %doc %{_mandir}/man1/*.1.gz
 
 %files devel
 %defattr(-, root, root)
 %{_libdir}/libwim.a
-%{_libdir}/libwim.la
+%{_libdir}/libwim.so
+%exclude %{_libdir}/libwim.la
 %{_includedir}/wimlib.h
 %{_libdir}/pkgconfig/wimlib.pc