]> wimlib.net Git - wimlib/blobdiff - archlinux/PKGBUILD
v1.9.1
[wimlib] / archlinux / PKGBUILD
index 1b6afd7725ecd12243ddca3752a2abaa91cf69b9..f30c691db763ee12007f6754d73e5b91304d61b4 100644 (file)
@@ -1,25 +1,22 @@
 # Maintainer:  Eric Biggers <ebiggers3 at gmail dot com>
 
 pkgname=wimlib
-pkgver=1.2.4
+pkgver=1.9.1
 pkgrel=1
-pkgdesc="A library to extract, create, and modify WIM files"
+pkgdesc="A library and program to extract, create, and modify WIM files"
 arch=("i686" "x86_64")
-url="http://sourceforge.net/projects/wimlib"
-license=("GPL3")
+url="https://wimlib.net"
+license=("custom")
 depends=("openssl" "fuse" "libxml2" "ntfs-3g" "attr")
 optdepends=("cdrkit: for making ISO image of Windows PE"
        "mtools: for making disk image of Windows PE"
        "syslinux: for making disk image of Windows PE"
-       "cabextract: for extracting Windows PE from the WAIK"
-       "ntfsprogs: for making NTFS filesystems")
-checkdepends=("ntfsprogs")
-source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
+       "cabextract: for extracting Windows PE from the WAIK")
+source=("https://wimlib.net/downloads/$pkgname-$pkgver.tar.gz")
 
 build() {
        cd "$pkgname-$pkgver"
-       ./configure --disable-verify-compression --with-libcrypto --with-fuse \
-                   --with-ntfs-3g --enable-xattr --prefix=/usr
+       ./configure --with-libcrypto --with-fuse --with-ntfs-3g --prefix=/usr
        make
 }
 
@@ -31,4 +28,10 @@ check() {
 package() {
        cd "$pkgname-$pkgver"
        make DESTDIR="$pkgdir" install
+       for file in NEWS README; do
+               install -Dm644 $file "$pkgdir/usr/share/doc/$pkgname/$file"
+       done
+       for file in COPYING*; do
+               install -Dm644 $file "$pkgdir/usr/share/licenses/$pkgname/$file"
+       done
 }