]> wimlib.net Git - wimlib/blobdiff - archlinux/PKGBUILD
wimlib.h: remove unused RESUME flag
[wimlib] / archlinux / PKGBUILD
index d479a62178cc78727bdf26c5f6a333fa93b967b8..b8195b1fce18c0c424ee08819b6e605c024b9e80 100644 (file)
@@ -1,12 +1,12 @@
 # Maintainer:  Eric Biggers <ebiggers3 at gmail dot com>
 
 pkgname=wimlib
-pkgver=1.2.1
+pkgver=1.8.3
 pkgrel=1
-pkgdesc="A library to extract, create, and modify WIM files"
+pkgdesc="A library and program to extract, create, and modify WIM files"
 arch=("i686" "x86_64")
-url="http://sourceforge.net/projects/wimlib"
-license=("GPL3")
+url="https://wimlib.net"
+license=("custom")
 depends=("openssl" "fuse" "libxml2" "ntfs-3g" "attr")
 optdepends=("cdrkit: for making ISO image of Windows PE"
        "mtools: for making disk image of Windows PE"
@@ -14,12 +14,11 @@ optdepends=("cdrkit: for making ISO image of Windows PE"
        "cabextract: for extracting Windows PE from the WAIK"
        "ntfsprogs: for making NTFS filesystems")
 checkdepends=("ntfsprogs")
-source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
+source=("https://wimlib.net/downloads/$pkgname-$pkgver.tar.gz")
 
 build() {
        cd "$pkgname-$pkgver"
-       ./configure --disable-verify-compression --with-libcrypto --with-fuse \
-                   --with-ntfs-3g --enable-xattr --prefix=/usr
+       ./configure --with-libcrypto --with-fuse --with-ntfs-3g --prefix=/usr
        make
 }
 
@@ -31,4 +30,10 @@ check() {
 package() {
        cd "$pkgname-$pkgver"
        make DESTDIR="$pkgdir" install
+       for file in NEWS README; do
+               install -Dm644 $file "$pkgdir/usr/share/doc/$pkgname/$file"
+       done
+       for file in COPYING*; do
+               install -Dm644 $file "$pkgdir/usr/share/licenses/$pkgname/$file"
+       done
 }