]> wimlib.net Git - wimlib/blobdiff - archlinux/PKGBUILD
wimlib-imagex: improve error message
[wimlib] / archlinux / PKGBUILD
index 31b1069599ddd1258ab941f63c89ba89951e23f0..994f63440c1c22ba92bb32ec4707dc6d2e520b82 100644 (file)
@@ -1,12 +1,12 @@
 # Maintainer:  Eric Biggers <ebiggers3 at gmail dot com>
 
 pkgname=wimlib
-pkgver=1.6.0
+pkgver=1.8.2
 pkgrel=1
 pkgdesc="A library and program to extract, create, and modify WIM files"
 arch=("i686" "x86_64")
-url="http://sourceforge.net/projects/wimlib"
-license=("GPL3")
+url="http://wimlib.net"
+license=("custom")
 depends=("openssl" "fuse" "libxml2" "ntfs-3g" "attr")
 optdepends=("cdrkit: for making ISO image of Windows PE"
        "mtools: for making disk image of Windows PE"
@@ -14,12 +14,11 @@ optdepends=("cdrkit: for making ISO image of Windows PE"
        "cabextract: for extracting Windows PE from the WAIK"
        "ntfsprogs: for making NTFS filesystems")
 checkdepends=("ntfsprogs")
-source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
+source=("http://wimlib.net/downloads/$pkgname-$pkgver.tar.gz")
 
 build() {
        cd "$pkgname-$pkgver"
-       ./configure --with-libcrypto --with-fuse --with-ntfs-3g \
-                       --enable-xattr --prefix=/usr
+       ./configure --with-libcrypto --with-fuse --with-ntfs-3g --prefix=/usr
        make
 }
 
@@ -31,7 +30,10 @@ check() {
 package() {
        cd "$pkgname-$pkgver"
        make DESTDIR="$pkgdir" install
-       for file in README NEWS README.WINDOWS; do
+       for file in NEWS README*; do
                install -Dm644 $file "$pkgdir/usr/share/doc/$pkgname/$file"
        done
+       for file in COPYING*; do
+               install -Dm644 $file "$pkgdir/usr/share/licenses/$pkgname/$file"
+       done
 }