]> wimlib.net Git - wimlib/blobdiff - archlinux/PKGBUILD
Update Linux packaging
[wimlib] / archlinux / PKGBUILD
index 28458460a511c04fa0092108f86b234042f81c91..027ca1c69fbe1e0191c8d0599de02845d7014030 100644 (file)
@@ -6,7 +6,7 @@ pkgrel=1
 pkgdesc="A library and program to extract, create, and modify WIM files"
 arch=("i686" "x86_64")
 url="http://sourceforge.net/projects/wimlib"
-license=("GPL3")
+license=("custom")
 depends=("openssl" "fuse" "libxml2" "ntfs-3g" "attr")
 optdepends=("cdrkit: for making ISO image of Windows PE"
        "mtools: for making disk image of Windows PE"
@@ -18,8 +18,7 @@ source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
 
 build() {
        cd "$pkgname-$pkgver"
-       ./configure --with-libcrypto --with-fuse --with-ntfs-3g \
-                       --enable-xattr --prefix=/usr
+       ./configure --with-libcrypto --with-fuse --with-ntfs-3g --prefix=/usr
        make
 }
 
@@ -31,7 +30,10 @@ check() {
 package() {
        cd "$pkgname-$pkgver"
        make DESTDIR="$pkgdir" install
-       for file in README NEWS README.WINDOWS; do
+       for file in NEWS README*; do
                install -Dm644 $file "$pkgdir/usr/share/doc/$pkgname/$file"
        done
+       for file in COPYING*; do
+               install -Dm644 $file "$pkgdir/usr/share/licenses/$pkgname/$file"
+       done
 }