]> wimlib.net Git - wimlib/blobdiff - archlinux/PKGBUILD.in
wimlib_select_image() => select_wim_image()
[wimlib] / archlinux / PKGBUILD.in
index 2417135e2b0df5dd1aab9f82c30257f1a64ac418..6ac24420524f15095d85d5548d93c9978841b397 100644 (file)
@@ -1,28 +1,37 @@
 # Maintainer:  Eric Biggers <ebiggers3 at gmail dot com>
 
+# Add md5sum and delete this line to complete the PKGBUILD
+
 pkgname=wimlib
 pkgver=@VERSION@
 pkgrel=1
 pkgdesc="A library to extract, create, and modify WIM files"
 arch=("i686" "x86_64")
 url="http://sourceforge.net/projects/wimlib"
-license=("LGPL")
-depends=("openssl" "fuse" "libxml2")
+license=("GPL3")
+depends=("openssl" "fuse" "libxml2" "ntfs-3g" "attr")
 optdepends=("cdrkit: for making ISO image of Windows PE"
        "mtools: for making disk image of Windows PE"   
        "syslinux: for making disk image of Windows PE" 
-       "cabextract: for extracting Windows PE from the WAIK")
-source=("$url/files/$pkgname-$pkgver.tar.gz")
-md5sums=("ce01547173dbac170b324dbb6fc84243")
+       "cabextract: for extracting Windows PE from the WAIK"
+       "ntfsprogs: for making NTFS filesystems")
+checkdepends=("ntfsprogs")
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
 
 build() {
        cd "$pkgname-$pkgver"
-       ./configure --disable-verify-compression --enable-libcrypto \
-                       --prefix=/usr
+       ./configure --disable-verify-compression --with-libcrypto --with-fuse \
+                   --with-ntfs-3g --enable-xattr --prefix=/usr
        make
 }
 
+check() {
+       cd "$pkgname-$pkgver"  
+       make check
+}
+
 package() {
        cd "$pkgname-$pkgver"  
        make DESTDIR="$pkgdir" install
 }
+