]> wimlib.net Git - wimlib/blobdiff - archlinux/PKGBUILD.in
Various packaging issues
[wimlib] / archlinux / PKGBUILD.in
diff --git a/archlinux/PKGBUILD.in b/archlinux/PKGBUILD.in
deleted file mode 100644 (file)
index d137fbf..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-# Maintainer:  Eric Biggers <ebiggers3 at gmail dot com>
-
-# Add md5sum and delete this line to complete the PKGBUILD
-
-pkgname=wimlib
-pkgver=@VERSION@
-pkgrel=1
-pkgdesc="A library to extract, create, and modify WIM files"
-arch=("i686" "x86_64")
-url="http://sourceforge.net/projects/wimlib"
-license=("GPL3")
-depends=("openssl" "fuse" "libxml2" "ntfs-3g" "attr")
-optdepends=("cdrkit: for making ISO image of Windows PE"
-       "mtools: for making disk image of Windows PE"
-       "syslinux: for making disk image of Windows PE"
-       "cabextract: for extracting Windows PE from the WAIK"
-       "ntfsprogs: for making NTFS filesystems")
-checkdepends=("ntfsprogs")
-source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
-
-build() {
-       cd "$pkgname-$pkgver"
-       ./configure --disable-verify-compression --with-libcrypto --with-fuse \
-                   --with-ntfs-3g --enable-xattr --prefix=/usr
-       make
-}
-
-check() {
-       cd "$pkgname-$pkgver"
-       make check
-}
-
-package() {
-       cd "$pkgname-$pkgver"
-       make DESTDIR="$pkgdir" install
-}
-