]> wimlib.net Git - wimlib/blob - rpm/wimtools.spec
Fix void** casts
[wimlib] / rpm / wimtools.spec
1 Summary:   Library to extract, create, modify, and mount WIM files
2 Name:      wimtools
3 Version:   1.5.0
4 Release:   1
5 License:   GPLv3+
6 URL:       http://sourceforge.net/projects/wimlib
7 Packager:  Eric Biggers <ebiggers3@gmail.com>
8 Source:    http://downloads.sourceforge.net/wimlib/wimlib-%{version}.tar.gz
9 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10
11 Requires: libxml2, libfuse2, fuse, openssl
12 Requires: ntfs-3g
13 BuildRequires: libxml2-devel, fuse, fuse-devel, openssl-devel, libattr-devel
14 BuildRequires: ntfs-3g-devel, ntfsprogs, libtool, pkg-config
15
16 Summary: Tools to create, extract, modify, and mount WIM files
17 Group:    Applications/System
18 Requires: libwim9
19 %description
20 Tools to extract, create, modify, and mount WIM (Windows Imaging) files.  WIM is
21 an archive format designed primarily for archiving Windows filesystems.  It
22 features single-instancing and LZ77-based compression and is used by Microsoft
23 to distribute and deploy Windows Vista and later.  WIM files are normally
24 created by using the `imagex.exe' utility on Windows, but this package contains
25 a free implementation of ImageX called "wimlib-imagex" that is designed to work
26 on both UNIX and Windows.
27
28 In addition to the usual extract/create/update support, wimlib-imagex allows you
29 to mount WIM images readonly or read-write, and it even allows you to extract or
30 create a WIM image directly to/from an unmounted NTFS volume.  This makes it
31 possible to, from Linux, back up or deploy a Windows OS directly to or from a
32 WIM file, such as the install.wim distributed on the Windows installation media.
33
34 This package also contains a script to make a customized Windows PE image based
35 on the capabilities provided by wimlib-imagex.
36
37 %package devel
38 Summary:  Development files for wimlib
39 Group:     System/Libraries
40 %description devel
41 Development files for wimlib
42
43 %package -n libwim9
44 Summary:   Library to extract, create, modify, and mount WIM files
45 Group:    Development/Libraries
46 %description -n libwim9
47 wimlib is a C library for extracting, creating, modifying, and mounting WIM
48 (Windows Imaging) files.  WIM is an archive format designed primarily for
49 archiving Windows filesystems.  It features single-instancing and LZ77-based
50 compression, and is used by Microsoft to distribute and deploy Windows Vista and
51 later.  wimlib is an independent implementation of an API for handling WIM
52 files, available on both UNIX and Windows, that provides features similar to
53 Microsoft's WIMGAPI, as well as additional features such as support for pipable
54 WIM files and programatically making changes to WIM images without mounting
55 them.
56 %post -n libwim9 -p /sbin/ldconfig
57 %postun -n libwim9 -p /sbin/ldconfig
58
59 %prep
60 %setup -q -n wimlib-%{version}
61
62 %build
63 autoreconf -i -f
64 %configure --prefix=/usr                \
65            --disable-rpath              \
66            --with-libcrypto             \
67            --with-ntfs-3g               \
68            --with-fuse                  \
69            --enable-xattr
70 make %{?_smp_mflags}
71
72 %install
73 rm -rf %{buildroot}
74 make DESTDIR=%{buildroot} install
75
76 %clean
77 rm -rf %{buildroot}
78
79
80 %files
81 %defattr(-, root, root)
82 %{_bindir}/*
83 %doc %{_mandir}/man1/*.1.gz
84 %doc %{_mandir}/man1/*.1
85
86 %files devel
87 %defattr(-, root, root)
88 %{_libdir}/libwim.a
89 %{_libdir}/libwim.so
90 %exclude %{_libdir}/libwim.la
91 %{_includedir}/wimlib.h
92 %{_libdir}/pkgconfig/wimlib.pc
93 %doc AUTHORS COPYING README
94
95 %files -n libwim9
96 %defattr(-, root, root)
97 %{_libdir}/libwim.so.*
98