]> wimlib.net Git - wimlib/blob - rpm/wimtools.spec
Update version number to 1.5.1
[wimlib] / rpm / wimtools.spec
1 Name:      wimtools
2 Summary:   Tools to create, extract, modify, and mount WIM files
3 Version:   1.5.1
4 Release:   1
5 License:   GPLv3+
6 URL:       http://sourceforge.net/projects/wimlib
7 Packager:  Eric Biggers <ebiggers3@gmail.com>
8 Source:    http://downloads.sourceforge.net/wimlib/wimlib-%{version}.tar.gz
9 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10
11
12 Group:  Applications/System
13 Requires: libwim9
14 %description
15 Tools to extract, create, modify, and mount WIM (Windows Imaging) files.  WIM is
16 an archive format designed primarily for archiving Windows filesystems.  It
17 features single-instancing and LZ77-based compression and is used by Microsoft
18 to distribute and deploy Windows Vista and later.  WIM files are normally
19 created by using the `imagex.exe' utility on Windows, but this package contains
20 a free implementation of ImageX called "wimlib-imagex" that is designed to work
21 on both UNIX-like systems and Windows.
22
23 In addition to the usual extract/create/update support, wimlib-imagex allows you
24 to mount WIM images readonly or read-write, and it even allows you to extract or
25 create a WIM image directly to/from an unmounted NTFS volume.  This makes it
26 possible to, from Linux, back up or deploy a Windows OS directly to or from a
27 WIM file, such as the install.wim distributed on the Windows installation media.
28
29 This package also contains a script to make a customized Windows PE image based
30 on the capabilities provided by wimlib-imagex.
31
32 %package -n libwim9-devel
33 Summary:  Development files for wimlib
34 Group:  Development/Libraries
35 %description -n libwim9-devel
36 Development files for wimlib
37
38 %package -n libwim9
39 Summary:  Library to extract, create, modify, and mount WIM files
40 Group:  System Environment/Libraries
41 Requires:  fuse
42 BuildRequires: libxml2-devel, fuse, fuse-devel, openssl-devel, libattr-devel
43 BuildRequires: ntfs-3g-devel, ntfsprogs, libtool, pkgconfig
44 %description -n libwim9
45 wimlib is a C library for extracting, creating, modifying, and mounting WIM
46 (Windows Imaging) files.  WIM is an archive format designed primarily for
47 archiving Windows filesystems.  It features single-instancing and LZ77-based
48 compression, and is used by Microsoft to distribute and deploy Windows Vista and
49 later.  wimlib is an independent implementation of an API for handling WIM
50 files, available on both UNIX-like systems and Windows, that provides features
51 similar to Microsoft's WIMGAPI, as well as additional features such as support
52 for pipable WIM files and programatically making changes to WIM images without
53 mounting them.
54 %post -n libwim9 -p /sbin/ldconfig
55 %postun -n libwim9 -p /sbin/ldconfig
56
57 %prep
58 %setup -q -n wimlib-%{version}
59
60 %build
61 %configure --prefix=/usr                \
62            --disable-rpath              \
63            --with-libcrypto             \
64            --with-ntfs-3g               \
65            --with-fuse                  \
66            --enable-xattr
67 make %{?_smp_mflags}
68
69 %install
70 rm -rf %{buildroot}
71 make DESTDIR=%{buildroot} install
72
73 %clean
74 rm -rf %{buildroot}
75
76 %files
77 %defattr(-, root, root)
78 %{_bindir}/*
79 %doc %{_mandir}/man1/*.1.gz
80 %doc README AUTHORS COPYING
81
82 %files -n libwim9-devel
83 %defattr(-, root, root)
84 %{_libdir}/libwim.a
85 %{_libdir}/libwim.so
86 %exclude %{_libdir}/libwim.la
87 %{_includedir}/wimlib.h
88 %{_libdir}/pkgconfig/wimlib.pc
89
90 %files -n libwim9
91 %defattr(-, root, root)
92 %{_libdir}/libwim.so.*
93 %doc COPYING