]> wimlib.net Git - wimlib/blob - rpm/wimlib.spec
print_lookup_table(): Print metadata entries
[wimlib] / rpm / wimlib.spec
1 Summary:   Library to extract, create, modify, and mount WIM files
2 Name:      wimlib
3 Version:   1.4.0
4 Release:   1
5 License:   GPLv3+
6 Group:     System/Libraries
7 URL:       http://sourceforge.net/projects/wimlib
8 Packager:  Eric Biggers <ebiggers3@gmail.com>
9 Source:    http://downloads.sourceforge.net/wimlib/wimlib-%{version}.tar.gz
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11
12 Requires: libxml2, fuse-libs, fuse, openssl
13 Requires: ntfs-3g >= 2:2011.4.12
14 BuildRequires: libxml2-devel, fuse, fuse-devel, openssl-devel, libattr-devel
15 BuildRequires: ntfs-3g-devel >= 2:2011.4.12, ntfsprogs
16 %description
17 wimlib is a C library for creating, extracting, modifying, and mounting files in
18 the Windows Imaging Format (WIM files).  It is similar to Microsoft's WIMGAPI
19 but is designed for both UNIX and Windows.
20
21 %package devel
22 Summary:  Development files for wimlib
23 Group:    Development/Libraries
24 Requires: %{name} = %{version}-%{release}
25 %description devel
26 Development files for wimlib
27
28 %package -n wimtools
29 Summary: Tools to create, extract, modify, and mount WIM files
30 Group:    Applications/System
31 Requires: %{name} = %{version}-%{release}
32 %description -n wimtools
33 Tools to create, extract, modify, and mount files in the Windows Imaging Format
34 (WIM files).  These files are normally created by using the `imagex.exe' utility
35 on Windows, but this package contains a free implementation of ImageX called
36 "wimlib-imagex" that is designed to work on both UNIX and Windows.
37
38 %prep
39 %setup -q -n %{name}-%{version}
40
41 %build
42 %configure --prefix=/usr                \
43            --disable-rpath              \
44            --with-libcrypto             \
45            --with-ntfs-3g               \
46            --with-fuse                  \
47            --enable-xattr
48 make %{?_smp_mflags}
49
50 %check
51 make check
52
53 %install
54 rm -rf %{buildroot}
55 make DESTDIR=%{buildroot} install
56
57 %clean
58 rm -rf %{buildroot}
59
60 %post -p /sbin/ldconfig
61 %postun -p /sbin/ldconfig
62
63 %files
64 %defattr(-, root, root)
65 %doc AUTHORS COPYING README
66 %{_libdir}/libwim.so.*
67
68 %files -n wimtools
69 %defattr(-, root, root)
70 %{_bindir}/wimlib-imagex
71 %{_bindir}/mkwinpeimg
72 %doc %{_mandir}/man1/*.1.gz
73
74 %files devel
75 %defattr(-, root, root)
76 %{_libdir}/libwim.a
77 %{_libdir}/libwim.so
78 %exclude %{_libdir}/libwim.la
79 %{_includedir}/wimlib.h
80 %{_libdir}/pkgconfig/wimlib.pc