]> wimlib.net Git - wimlib/blob - rpm/wimlib.spec
4ab654dc0c815276268aa6e0d6f2d53e256e46f9
[wimlib] / rpm / wimlib.spec
1 Summary:   Library to extract, create, and modify WIM files
2 Name:      wimlib
3 Version:   1.1.0
4 Release:   1
5 License:   GPLv3+
6 Group:     System/Libraries
7 URL:       http://wimlib.sourceforge.net
8 Packager:  Eric Biggers <ebiggers3@gmail.com>
9 Source:    http://downloads.sourceforge.net/wimlib/wimlib-%{version}.tar.gz
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11
12 Requires: libxml2, fuse-libs, fuse, openssl
13 Requires: ntfs-3g >= 2:2011.4.12
14 BuildRequires: libxml2-devel, fuse, fuse-devel, openssl-devel, libattr-devel
15 BuildRequires: ntfs-3g-devel >= 2:2011.4.12, ntfsprogs
16 %description
17 wimlib is a library that can be used to create, extract, and modify files in the
18 Windows Imaging Format. These files are normally created by the 'imagex.exe'
19 program on Windows, but this library provides a free implementation of 'imagex'
20 for UNIX-based systems. wimlib supports mounting WIM files, just like
21 imagex.exe.
22
23 %package devel
24 Summary:  Development files for wimlib
25 Group:    Development/Libraries
26 Requires: %{name} = %{version}-%{release}
27 %description devel
28 Development files for wimlib
29
30 %prep
31 %setup -q -n %{name}-%{version}
32
33 %build
34 %configure --prefix=/usr                 \
35            --disable-rpath               \
36            --with-libcrypto              \
37            --with-ntfs-3g                \
38            --enable-xattr                \
39            --disable-verify-compression
40 %__make %{?_smp_mflags}
41
42 %check
43 make check
44
45 %install
46 %__rm -rf %{buildroot}
47 %__make DESTDIR=%{buildroot} install
48
49 %clean
50 %__rm -rf %{buildroot}
51
52 %post -p /sbin/ldconfig
53 %postun -p /sbin/ldconfig
54
55 %files
56 %defattr(-, root, root)
57 %doc AUTHORS COPYING README TODO
58 %{_bindir}/imagex
59 %{_bindir}/mkwinpeimg
60 %{_libdir}/libwim.so
61 %{_libdir}/libwim.so.0
62 %{_libdir}/libwim.so.0.0.0
63 %doc %{_mandir}/man1/*.1.gz
64
65 %files devel
66 %defattr(-, root, root)
67 %{_libdir}/libwim.a
68 %{_libdir}/libwim.la
69 %{_includedir}/wimlib.h
70 %{_libdir}/pkgconfig/wimlib.pc