]> wimlib.net Git - wimlib/blob - rpm/wimlib-without-ntfs-3g.spec
Win32: Do not set file attributes on root directory
[wimlib] / rpm / wimlib-without-ntfs-3g.spec
1 Summary:   Library to extract, create, and modify WIM files
2 Name:      wimlib
3 Version:   1.3.3
4 Release:   1
5 License:   GPLv3+
6 Group:     System/Libraries
7 URL:       http://wimlib.sourceforge.net
8 Packager:  Eric Biggers <ebiggers3@gmail.com>
9 Source:    http://downloads.sourceforge.net/wimlib/wimlib-%{version}.tar.gz
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11
12 Requires: libxml2, fuse-libs, fuse, openssl
13 BuildRequires: libxml2-devel, fuse-devel, openssl-devel, libattr-devel, fuse
14 %description
15 wimlib is a library that can be used to create, extract, and modify files in the
16 Windows Imaging Format. These files are normally created by the 'imagex.exe'
17 program on Windows, but this library provides a free implementation of 'imagex'
18 for UNIX-based systems. wimlib supports mounting WIM files, just like
19 imagex.exe.
20
21 %package devel
22 Summary:  Development files for wimlib
23 Group:    Development/Libraries
24 Requires: %{name} = %{version}-%{release}
25 %description devel
26 Development files for wimlib
27
28 %prep
29 %setup -q -n %{name}-%{version}
30
31 %build
32 %configure --prefix=/usr                 \
33            --disable-rpath               \
34            --with-libcrypto              \
35            --without-ntfs-3g             \
36            --enable-xattr
37 %__make %{?_smp_mflags}
38
39 %check
40 make check
41
42 %install
43 %__rm -rf %{buildroot}
44 %__make DESTDIR=%{buildroot} install
45
46 %clean
47 %__rm -rf %{buildroot}
48
49 %post -p /sbin/ldconfig
50 %postun -p /sbin/ldconfig
51
52 %files
53 %defattr(-, root, root)
54 %doc AUTHORS COPYING README TODO
55 %{_bindir}/imagex
56 %{_bindir}/mkwinpeimg
57 %{_libdir}/libwim.so*
58 %doc %{_mandir}/man1/*.1.gz
59
60 %files devel
61 %defattr(-, root, root)
62 %{_libdir}/libwim.a
63 %{_libdir}/libwim.la
64 %{_includedir}/wimlib.h
65 %{_libdir}/pkgconfig/wimlib.pc