]> wimlib.net Git - wimlib/blob - rpm/wimlib-without-fuse-or-ntfs-3g.spec
compare_utf16le_names_case_insensitive(): Use _wcsnicmp()
[wimlib] / rpm / wimlib-without-fuse-or-ntfs-3g.spec
1 Summary:   Library to extract, create, modify, and mount WIM files
2 Name:      wimlib
3 Version:   1.4.0
4 Release:   1
5 License:   GPLv3+
6 Group:     System/Libraries
7 URL:       http://sourceforge.net/projects/wimlib
8 Packager:  Eric Biggers <ebiggers3@gmail.com>
9 Source:    http://downloads.sourceforge.net/wimlib/wimlib-%{version}.tar.gz
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11
12 Requires: libxml2, openssl
13 BuildRequires: libxml2-devel, openssl-devel
14 %description
15 wimlib is a C library for creating, extracting, modifying, and mounting files in
16 the Windows Imaging Format (WIM files).  It is similar to Microsoft's WIMGAPI
17 but is designed for both UNIX and Windows.
18
19 %package devel
20 Summary:  Development files for wimlib
21 Group:    Development/Libraries
22 Requires: %{name} = %{version}-%{release}
23 %description devel
24 Development files for wimlib
25
26 %package -n wimtools
27 Summary: Tools to create, extract, modify, and mount WIM files
28 Group:    Applications/System
29 Requires: %{name} = %{version}-%{release}
30 %description -n wimtools
31 Tools to create, extract, modify, and mount files in the Windows Imaging Format
32 (WIM files).  These files are normally created by using the `imagex.exe' utility
33 on Windows, but this package contains a free implementation of ImageX called
34 "wimlib-imagex" that is designed to work on both UNIX and Windows.
35
36 %prep
37 %setup -q -n %{name}-%{version}
38
39 %build
40 %configure --prefix=/usr                \
41            --disable-rpath              \
42            --with-libcrypto             \
43            --without-ntfs-3g            \
44            --without-fuse               \
45            --disable-xattr
46 make %{?_smp_mflags}
47
48 %check
49 make check
50
51 %install
52 rm -rf %{buildroot}
53 make DESTDIR=%{buildroot} install
54
55 %clean
56 rm -rf %{buildroot}
57
58 %post -p /sbin/ldconfig
59 %postun -p /sbin/ldconfig
60
61 %files
62 %defattr(-, root, root)
63 %doc AUTHORS COPYING README
64 %{_libdir}/libwim.so.*
65
66 %files -n wimtools
67 %defattr(-, root, root)
68 %{_bindir}/wimlib-imagex
69 %{_bindir}/mkwinpeimg
70 %doc %{_mandir}/man1/*.1.gz
71
72 %files devel
73 %defattr(-, root, root)
74 %{_libdir}/libwim.a
75 %{_libdir}/libwim.so
76 %exclude %{_libdir}/libwim.la
77 %{_includedir}/wimlib.h
78 %{_libdir}/pkgconfig/wimlib.pc