]> wimlib.net Git - wimlib/blob - rpm/wimlib-minimal.spec
Add win32-test-imagex-capture_and_apply.bat
[wimlib] / rpm / wimlib-minimal.spec
1 Summary:   Library to extract, create, and modify WIM files
2 Name:      wimlib
3 Version:   1.3.3
4 Release:   1
5 License:   GPLv3+
6 Group:     System/Libraries
7 URL:       http://wimlib.sourceforge.net
8 Packager:  Eric Biggers <ebiggers3@gmail.com>
9 Source:    http://downloads.sourceforge.net/wimlib/wimlib-%{version}.tar.gz
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11
12 Requires: libxml2, openssl
13 BuildRequires: libxml2-devel, openssl-devel
14 %description
15 wimlib is a library that can be used to create, extract, and modify files in the
16 Windows Imaging Format. These files are normally created by the 'imagex.exe'
17 program on Windows, but this library provides a free implementation of 'imagex'
18 for UNIX-based systems. wimlib supports mounting WIM files, just like
19 imagex.exe.
20
21 %package devel
22 Summary:  Development files for wimlib
23 Group:    Development/Libraries
24 Requires: %{name} = %{version}-%{release}
25 %description devel
26 Development files for wimlib
27
28 %prep
29 %setup -q -n %{name}-%{version}
30
31 %build
32 %configure --prefix=/usr                 \
33            --disable-rpath               \
34            --with-libcrypto              \
35            --without-ntfs-3g             \
36            --without-fuse                \
37            --disable-xattr               \
38            --disable-multithreaded-compression \
39            --disable-custom-memory-allocator \
40            --disable-assertions
41 %__make %{?_smp_mflags}
42
43 %check
44 make check
45
46 %install
47 %__rm -rf %{buildroot}
48 %__make DESTDIR=%{buildroot} install
49
50 %clean
51 %__rm -rf %{buildroot}
52
53 %post -p /sbin/ldconfig
54 %postun -p /sbin/ldconfig
55
56 %files
57 %defattr(-, root, root)
58 %doc AUTHORS COPYING README TODO
59 %{_bindir}/imagex
60 %{_bindir}/mkwinpeimg
61 %{_libdir}/libwim.so*
62 %doc %{_mandir}/man1/*.1.gz
63
64 %files devel
65 %defattr(-, root, root)
66 %{_libdir}/libwim.a
67 %{_libdir}/libwim.la
68 %{_includedir}/wimlib.h
69 %{_libdir}/pkgconfig/wimlib.pc