]> wimlib.net Git - wimlib/blob - rpm/wimlib-minimal.spec
1e2d4594cbf36cc8348a827a197d6b31dbf05347
[wimlib] / rpm / wimlib-minimal.spec
1 Summary:   Library to extract, create, and modify WIM files
2 Name:      wimlib
3 Version:   1.1.0
4 Release:   1
5 License:   GPLv3+
6 Group:     System/Libraries
7 URL:       http://wimlib.sourceforge.net
8 Packager:  Eric Biggers <ebiggers3@gmail.com>
9 Source:    http://downloads.sourceforge.net/wimlib/wimlib-%{version}.tar.gz
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11
12 Requires: libxml2, openssl
13 BuildRequires: libxml2-devel, openssl-devel
14 %description
15 wimlib is a library that can be used to create, extract, and modify files in the
16 Windows Imaging Format. These files are normally created by the 'imagex.exe'
17 program on Windows, but this library provides a free implementation of 'imagex'
18 for UNIX-based systems. wimlib supports mounting WIM files, just like
19 imagex.exe.
20
21 %package devel
22 Summary:  Development files for wimlib
23 Group:    Development/Libraries
24 Requires: %{name} = %{version}-%{release}
25 %description devel
26 Development files for wimlib
27
28 %prep
29 %setup -q -n %{name}-%{version}
30
31 %build
32 %configure --prefix=/usr                 \
33            --disable-rpath               \
34            --with-libcrypto              \
35            --without-ntfs-3g             \
36            --without-fuse                \
37            --disable-xattr               \
38            --disable-verify-compression  \
39            --disable-multithreaded-compression \
40            --disable-custom-memory-allocator \
41            --disable-assertions
42 %__make %{?_smp_mflags}
43
44 %check
45 make check
46
47 %install
48 %__rm -rf %{buildroot}
49 %__make DESTDIR=%{buildroot} install
50
51 %clean
52 %__rm -rf %{buildroot}
53
54 %post -p /sbin/ldconfig
55 %postun -p /sbin/ldconfig
56
57 %files
58 %defattr(-, root, root)
59 %doc AUTHORS COPYING README TODO
60 %{_bindir}/imagex
61 %{_bindir}/mkwinpeimg
62 %{_libdir}/libwim.so*
63 %doc %{_mandir}/man1/*.1.gz
64
65 %files devel
66 %defattr(-, root, root)
67 %{_libdir}/libwim.a
68 %{_libdir}/libwim.la
69 %{_includedir}/wimlib.h
70 %{_libdir}/pkgconfig/wimlib.pc