]> wimlib.net Git - wimlib/blob - archlinux/PKGBUILD
v1.8.2
[wimlib] / archlinux / PKGBUILD
1 # Maintainer:  Eric Biggers <ebiggers3 at gmail dot com>
2
3 pkgname=wimlib
4 pkgver=1.8.2
5 pkgrel=1
6 pkgdesc="A library and program to extract, create, and modify WIM files"
7 arch=("i686" "x86_64")
8 url="http://wimlib.net"
9 license=("custom")
10 depends=("openssl" "fuse" "libxml2" "ntfs-3g" "attr")
11 optdepends=("cdrkit: for making ISO image of Windows PE"
12         "mtools: for making disk image of Windows PE"
13         "syslinux: for making disk image of Windows PE"
14         "cabextract: for extracting Windows PE from the WAIK"
15         "ntfsprogs: for making NTFS filesystems")
16 checkdepends=("ntfsprogs")
17 source=("http://wimlib.net/downloads/$pkgname-$pkgver.tar.gz")
18
19 build() {
20         cd "$pkgname-$pkgver"
21         ./configure --with-libcrypto --with-fuse --with-ntfs-3g --prefix=/usr
22         make
23 }
24
25 check() {
26         cd "$pkgname-$pkgver"
27         make check
28 }
29
30 package() {
31         cd "$pkgname-$pkgver"
32         make DESTDIR="$pkgdir" install
33         for file in NEWS README*; do
34                 install -Dm644 $file "$pkgdir/usr/share/doc/$pkgname/$file"
35         done
36         for file in COPYING*; do
37                 install -Dm644 $file "$pkgdir/usr/share/licenses/$pkgname/$file"
38         done
39 }