]> wimlib.net Git - wimlib/blob - archlinux/PKGBUILD
v1.9.2-BETA
[wimlib] / archlinux / PKGBUILD
1 # Maintainer:  Eric Biggers <ebiggers3 at gmail dot com>
2
3 pkgname=wimlib
4 pkgver=1.9.1
5 pkgrel=1
6 pkgdesc="A library and program to extract, create, and modify WIM files"
7 arch=("i686" "x86_64")
8 url="https://wimlib.net"
9 license=("custom")
10 depends=("openssl" "fuse" "libxml2" "ntfs-3g" "attr")
11 optdepends=("cdrkit: for making ISO image of Windows PE"
12         "mtools: for making disk image of Windows PE"
13         "syslinux: for making disk image of Windows PE"
14         "cabextract: for extracting Windows PE from the WAIK")
15 source=("https://wimlib.net/downloads/$pkgname-$pkgver.tar.gz")
16
17 build() {
18         cd "$pkgname-$pkgver"
19         ./configure --with-libcrypto --with-fuse --with-ntfs-3g --prefix=/usr
20         make
21 }
22
23 check() {
24         cd "$pkgname-$pkgver"
25         make check
26 }
27
28 package() {
29         cd "$pkgname-$pkgver"
30         make DESTDIR="$pkgdir" install
31         for file in NEWS README; do
32                 install -Dm644 $file "$pkgdir/usr/share/doc/$pkgname/$file"
33         done
34         for file in COPYING*; do
35                 install -Dm644 $file "$pkgdir/usr/share/licenses/$pkgname/$file"
36         done
37 }