]> wimlib.net Git - wimlib/blob - archlinux/PKGBUILD
$srcdir fix
[wimlib] / archlinux / PKGBUILD
1 # Maintainer:  Eric Biggers <ebiggers3 at gmail dot com>
2
3 # Add md5sum and delete this line to complete the PKGBUILD
4
5 pkgname=wimlib
6 pkgver=1.0.4
7 pkgrel=1
8 pkgdesc="A library to extract, create, and modify WIM files"
9 arch=("i686" "x86_64")
10 url="http://sourceforge.net/projects/wimlib"
11 license=("GPL3")
12 depends=("openssl" "fuse" "libxml2" "ntfs-3g" "attr")
13 optdepends=("cdrkit: for making ISO image of Windows PE"
14         "mtools: for making disk image of Windows PE"
15         "syslinux: for making disk image of Windows PE"
16         "cabextract: for extracting Windows PE from the WAIK"
17         "ntfsprogs: for making NTFS filesystems")
18 checkdepends=("ntfsprogs")
19 source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
20
21 build() {
22         cd "$pkgname-$pkgver"
23         ./configure --disable-verify-compression --with-libcrypto --with-fuse \
24                     --with-ntfs-3g --enable-xattr --prefix=/usr
25         make
26 }
27
28 check() {
29         cd "$pkgname-$pkgver"
30         make check
31 }
32
33 package() {
34         cd "$pkgname-$pkgver"
35         make DESTDIR="$pkgdir" install
36 }
37