]> wimlib.net Git - wimlib/blob - archlinux/PKGBUILD
Support for encrypted restore
[wimlib] / archlinux / PKGBUILD
1 # Maintainer:  Eric Biggers <ebiggers3 at gmail dot com>
2
3 pkgname=wimlib
4 pkgver=1.3.3
5 pkgrel=1
6 pkgdesc="A library to extract, create, and modify WIM files"
7 arch=("i686" "x86_64")
8 url="http://sourceforge.net/projects/wimlib"
9 license=("GPL3")
10 depends=("openssl" "fuse" "libxml2" "ntfs-3g" "attr")
11 optdepends=("cdrkit: for making ISO image of Windows PE"
12         "mtools: for making disk image of Windows PE"
13         "syslinux: for making disk image of Windows PE"
14         "cabextract: for extracting Windows PE from the WAIK"
15         "ntfsprogs: for making NTFS filesystems")
16 checkdepends=("ntfsprogs")
17 source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
18
19 build() {
20         cd "$pkgname-$pkgver"
21         ./configure --with-libcrypto --with-fuse --with-ntfs-3g \
22                         --enable-xattr --prefix=/usr
23         make
24 }
25
26 check() {
27         cd "$pkgname-$pkgver"
28         make check
29 }
30
31 package() {
32         cd "$pkgname-$pkgver"
33         make DESTDIR="$pkgdir" install
34         for file in README NEWS README.WINDOWS; do
35                 install -Dm644 $file "$pkgdir/usr/share/doc/$pkgname/$file"
36         done
37 }