]> wimlib.net Git - wimlib/blob - archlinux/PKGBUILD
remove dead variable store
[wimlib] / archlinux / PKGBUILD
1 # Maintainer:  Eric Biggers <ebiggers3 at gmail dot com>
2
3 pkgname=wimlib
4 pkgver=1.2.6
5 pkgrel=1
6 pkgdesc="A library to extract, create, and modify WIM files"
7 arch=("i686" "x86_64")
8 url="http://sourceforge.net/projects/wimlib"
9 license=("GPL3")
10 depends=("openssl" "fuse" "libxml2" "ntfs-3g" "attr")
11 optdepends=("cdrkit: for making ISO image of Windows PE"
12         "mtools: for making disk image of Windows PE"
13         "syslinux: for making disk image of Windows PE"
14         "cabextract: for extracting Windows PE from the WAIK"
15         "ntfsprogs: for making NTFS filesystems")
16 checkdepends=("ntfsprogs")
17 source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
18
19 build() {
20         cd "$pkgname-$pkgver"
21         ./configure --disable-verify-compression --with-libcrypto --with-fuse \
22                     --with-ntfs-3g --enable-xattr --prefix=/usr
23         make
24 }
25
26 check() {
27         cd "$pkgname-$pkgver"
28         make check
29 }
30
31 package() {
32         cd "$pkgname-$pkgver"
33         make DESTDIR="$pkgdir" install
34         install -Dm644 README "$pkgdir/usr/share/doc/$pkgname/README"
35         install -Dm644 NEWS "$pkgdir/usr/share/doc/$pkgname/NEWS"
36 }