]> wimlib.net Git - wimlib/blob - archlinux/PKGBUILD.in
3dd48fcde3ed828622238e1ee544a51a635bb7fa
[wimlib] / archlinux / PKGBUILD.in
1 # Maintainer:  Eric Biggers <ebiggers3 at gmail dot com>
2
3 # Set and $md5sums and delete this line to complete the PKGBUILD
4
5 pkgname=wimlib
6 pkgver=@VERSION@
7 pkgrel=1
8 pkgdesc="A library to extract, create, and modify WIM files"
9 arch=("i686" "x86_64")
10 url="http://sourceforge.net/projects/wimlib"
11 license=("LGPL")
12 depends=("openssl" "fuse" "libxml2")
13 optdepends=("cdrkit: for making ISO image of Windows PE"
14         "mtools: for making disk image of Windows PE"   
15         "syslinux: for making disk image of Windows PE" 
16         "cabextract: for extracting Windows PE from the WAIK")
17 source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
18 md5sums=("")
19
20 build() {
21         cd "$pkgname-$pkgver"
22         ./configure --disable-verify-compression --with-libcrypto \
23                         --prefix=/usr
24         make
25 }
26
27 package() {
28         cd "$pkgname-$pkgver"  
29         make DESTDIR="$pkgdir" install
30 }