Strange Start Menu / Microsoft Store app issue

Comments, questions, bug reports, etc.
Post Reply
Posts: 1
Joined: Thu Jan 05, 2017 2:49 am

Strange Start Menu / Microsoft Store app issue

Post by tperfitt »

This seems like a user space issue, rather than a wimlib issue, but I am at a loss to explain the behavior. In the past, I have been able to use wimcapture to capture a Windows 10 installation in macOS and restore it successfully using wimapply. However, after the latest Windows 10 Creators Update, the capture and apply work without any errors in the log, but the Start Menu and all Microsoft Store apps do not launch. If I try and launch them manually (for instance, using "start microsoft-edge"), I get a "invalid value for registry". If I use ntfsprogs to capture an image using the block-based special format, and restore, it works fine (no issue with the store apps or start menu). I have tried resetting the store apps with wsreset.exe and re-registering the apps, but nothing seems to work. I suspected that it had to do with the volume label or volume id that is store somewhere in the registry, but I did a wimapply on a NTFS formatted filesystem that was working but just had the same files removed. It showed the same behavior of the broken start menu and Microsoft store apps.

Any idea of why I see this behavior when restoring via wimcapture/apply?

Posts: 1
Joined: Sat Jan 19, 2019 3:18 am

Re: Strange Start Menu / Microsoft Store app issue

Post by jmwim »

I have upgraded wimlib to 1.13.0 and still have the same problem in Windows 10 when a capture of C: drive is immediately applied.

Start menu don't work. Anything that requires ms-settings (for example, display properties) gives an alert box with:

--- cut here ---
ms-settings: (_whatever_)

This file does not have a program associated with it for performing this action. Please install a program or, if on is already installed, create an association in the Default Programs control panel.
--- cut here ---

ntfsclone works for Windows 10 as expected. I used to do this capture/apply for my Windows 7 C: drive all the time and had no issues.

> tperfitt

Have you tried to restore volume label and/or id to match the original? I will try it myself and see what happens.
Posts: 1
Joined: Tue Jun 18, 2019 11:16 pm

Re: Strange Start Menu / Microsoft Store app issue

Post by tlhonmey »

It's something to do with the capture process I expect. .wim files created with Microsoft's DISM program work fine still. Wim files created with wimlib have start menu problems even when deployed with DISM.

My workflow doesn't really involve trying to deploy .wim files created with DISM via wimlib. Testing that would be a good idea.

Is there some new extended file attribute or permission that's not being correctly captured? It smells kind of like that, but I'm not sure how to test such things.
Posts: 34
Joined: Thu Aug 06, 2015 7:09 am

Re: Strange Start Menu / Microsoft Store app issue

Post by zipmagic »

My transparent disk compression software (which also doubles as my imaging and cloning solution) makes use of both wimlib and wimgapi (Microsoft). I always try to test as many PC images as I can find. I never run into any issues I can't fix. Except:

I found one image where, after compression, modern style ms office apps wouldn't launch. They could still be repaired. They also could be excluded from the compression process to ensure that the issue wouldn't happen. This was an image acquired from an Asus TUF Gaming notebook - their gaming budget line. It also reproduced in VMs, so definitely something to do with the OS image. Like you, I suspect extended attributes, security settings, and similar.

Even on other Asus products - like the ZenBook Pro Duo I recently sampled - this issue does *not* occur.

In my case, differently from yours though; the issue also occurs with wimgapi - both when invoked from my software (, or externally from the command line; without involving my software and wimlib at all. The results and failures were identical.

At that point I gave up researching this issue. It would be interesting to know whether my software worked on your PCs with/without wimlib.
Post Reply