Wimlib Apply Boot

Comments, questions, bug reports, etc.
Post Reply
laddanator
Posts: 4
Joined: Sun Apr 22, 2018 11:44 am

Wimlib Apply Boot

Post by laddanator »

Hello,

I am new to the forum as I am new to wimlib. I'm loving this program so far!! I have a 600mb Win PE boot wim that I use to do a lot of my work in a "Virtual Windows" environment. I applied the wim to a folder to make some changes to some system file, and then used the capture command to put my new files into a wim, and the wim would not boot. I was able to add --boot option to the end of the capture command line, and my little wim booted fine.

I am having an issue getting a Win 7 or Win 10 wim to boot after I have applied with wimlib to a hard drive. I use this command to capture the WIM

Code: Select all

wimlib-imagex.exe capture %WinDrive% 10Pro.wim "Win 10 PRO" --compress=LZX --boot 
and this command to apply the WIM

Code: Select all

wimlib-imagex.exe apply Y:\WINSETUP\Win10Pro\10Pro.wim 1 %WinDrive% 
But after the apply command finishes, and I reboot the computer, and I get this error which was the same error I got on my little Win PE wim when it tried to boot before I did a capture using the --boot option.

Image

Any advice would be much appreciated! :)
Skyblue
Posts: 18
Joined: Fri Apr 08, 2016 7:12 am

Re: Wimlib Apply Boot

Post by Skyblue »

Hello,

After restoring the backup, did you try to recreate the BCD store in the WinPE environment?

Code: Select all

bcdboot C:\Windows /s C:
T-S
Posts: 5
Joined: Mon Apr 16, 2018 6:08 pm

Re: Wimlib Apply Boot

Post by T-S »

Maybe I'm missing something but whats the point of capturing with the --boot switch on a normal system.

Isn't that meant only for PE wims and alike?
laddanator
Posts: 4
Joined: Sun Apr 22, 2018 11:44 am

Re: Wimlib Apply Boot

Post by laddanator »

Skyblue wrote: Mon Apr 23, 2018 9:46 am Hello,

After restoring the backup, did you try to recreate the BCD store in the WinPE environment?

Code: Select all

bcdboot C:\Windows /s C:
This seemed to do the trick....thanks!!
T-S wrote: Tue Apr 24, 2018 2:02 pm Maybe I'm missing something but whats the point of capturing with the --boot switch on a normal system.

Isn't that meant only for PE wims and alike?
I was just testing different options. The --boot option is not needed on what I was trying to do.
Post Reply